[testing] PC ne boot plus

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

[testing] PC ne boot plus

Gaëtan PERRIER-3
Bonjour,

Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir lancer
debian.
Quelqu'un d'autre rencontre-t'il ce problème?

A+

Gaëtan

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [testing] PC ne boot plus

haricophile@aranha.fr
Le Mon, 05 Nov 2018 23:23:17 +0100,
Gaëtan Perrier <[hidden email]> a écrit :

> Bonjour,
>
> Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
> Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir lancer
> debian.
> Quelqu'un d'autre rencontre-t'il ce problème?

Non, mais ça ne serait pas un problème UFI, voire un grub-pc remplaçant un
grub-efi ?

Reply | Threaded
Open this post in threaded view
|

Re: [testing] PC ne boot plus

Pierre ESTREM
In reply to this post by Gaëtan PERRIER-3
Bonjour,

Il m'est arrivé de perdre le GRUB2 de mon système base Debian Jessie.

Pour restaurer ce GRUB je boote sur une clé comportant le même grub et
je fais :
$ sudo grub-install /dev/sdx
( /devsdx est le ddur dont le GRUB est HS)

Si tu suis cette méthode avec TA clé tu devrais pouvoir booter sur ton
disque.

pierre estrem


Le 05/11/2018 à 23:23, Gaëtan Perrier a écrit :

> Bonjour,
>
> Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
> Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir lancer
> debian.
> Quelqu'un d'autre rencontre-t'il ce problème?
>
> A+
>
> Gaëtan

Reply | Threaded
Open this post in threaded view
|

Re: [testing] PC ne boot plus

ajh-valmer
In reply to this post by Gaëtan PERRIER-3
On Monday 05 November 2018 23:23:17 Gaëtan Perrier wrote:
> Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
> Pour démarrer je suis obligé de booter avec une clé rEFInd pour
> pouvoir lancer
> debian.
> Quelqu'un d'autre rencontre-t'il ce problème?

Oui, je l'ai souvent.

Quel message as tu lors du boot ?

Je résoud le problème en éditant le fichier "/boot/grub/grub.cfg"
et constate que les UUID dans une séquence de boot
ne sont pas les mêmes (donc crash assuré au boot).
Et pourtant avant, j'avais tapé "update-grub2".

Il est aussi préférable de copier le même grub.cfg
sur toutes les partitions Linux de ton ordinateur.

Une fois les bons UUID remis, je tape :
grub-install /dev/sda
et ça remarche.

Mais peut-être chez toi, c'est une autre cause ?

Bonne journée,

A. Valmer

Reply | Threaded
Open this post in threaded view
|

Re: [testing] PC ne boot plus

Pascal Hambourg-2
In reply to this post by Gaëtan PERRIER-3
Le 05/11/2018 à 23:23, Gaëtan Perrier a écrit :
>
> Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.

C'est-à-dire ? Qu'est-il censé se passer et que se passe-t-il ?

> Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir lancer
> debian.

Donc amorçage EFI avec grub-efi-*, je présume.
Une fois le système démarré, qu'affiche

efibootmgr -v

Reply | Threaded
Open this post in threaded view
|

Re: [testing] PC ne boot plus

Pascal Hambourg-2
In reply to this post by haricophile@aranha.fr
Le 06/11/2018 à 00:09, Haricophile a écrit :
>
> Non, mais ça ne serait pas un problème UFI, voire un grub-pc remplaçant un
> grub-efi ?

Le remplacement du *paquet* grub-efi par le *paquet* grub-pc ne
remplacerait pas le *chargeur* GRUB EFI par le *chargeur* GRUB BIOS.

Reply | Threaded
Open this post in threaded view
|

Re: [testing] PC ne boot plus

Gaëtan PERRIER-3
In reply to this post by Pascal Hambourg-2
Le mardi 06 novembre 2018 à 19:48 +0100, Pascal Hambourg a écrit :
> Le 05/11/2018 à 23:23, Gaëtan Perrier a écrit :
> > Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
>
> C'est-à-dire ? Qu'est-il censé se passer et que se passe-t-il ?

Le système est censé démarré et là il ne démarre pas ...
Il demande d'insérer un disque de boot.

>
> > Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir
> > lancer
> > debian.
>
> Donc amorçage EFI avec grub-efi-*, je présume.

Tout à fait.

> Une fois le système démarré, qu'affiche
>
> efibootmgr -v


# efibootmgr -v
BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0002,0003,0001
Boot0001* CD/DVD Drive BBS(CDROM,,0x0)AMGOAMNO........o.P.L.E.X.T.O.R.
.D.V.D.R. . . .P.X.-
.8.8.0.S.A....................A...........................>..Gd-.;.A..MQ..L. .
. . . . . . . . . . . . . . . . . . ......AMBO
Boot0002* Hard Drive BBS(HD,,0x0)AMGOAMNO........o.C.r.u.c.i.a.l._.C.T.2.5.0
.M.X.2.0.0.S.S.D.1....................A...........................>..Gd-
.;.A..MQ..L. . . . . . . .
.5.1.5.0.E.0.E.9.4.6.F.E......AMBOAMNO........o.C.3.0.0.-
.C.T.F.D.D.A.C.0.6.4.M.A.G....................A...........................>..Gd
-.;.A..MQ..L.0.0.0.0.0.0.0.0.1.1.6.1.3.0.5.0.2.B.9.C......AMBOAMNO........o.T.O
.S.H.I.B.A.
.D.T.0.1.A.C.A.2.0.0....................A...........................>..Gd-
.;.A..MQ..L. . . . . . . . . . .4.
.R.5.8.6.Y.D.S.A......AMBOAMNOu.......[.C.B.M....................A.............
...............................Gd-.;.A..MQ..L.C.B.M......AMBO
Boot0003* UEFI: CBM PciRoot(0x0)/Pci(0x1c,0x7)/Pci(0x0,0x0)/USB(3,0)/USB(1,
0)/USB(1,0)/HD(1,GPT,30d07d2b-cd7f-44d6-aa6f-db03ee9f3911,0x800,0x2f9f)AMBO
Boot0004  Crucial_CT250MX200SSD1 BBS(HD,,0x0)AMBO

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [testing] PC ne boot plus

Gaëtan PERRIER-3
In reply to this post by ajh-valmer
Le mardi 06 novembre 2018 à 09:38 +0100, ajh-valmer a écrit :

> On Monday 05 November 2018 23:23:17 Gaëtan Perrier wrote:
> > Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
> > Pour démarrer je suis obligé de booter avec une clé rEFInd pour
> > pouvoir lancer
> > debian.
> > Quelqu'un d'autre rencontre-t'il ce problème?
>
> Oui, je l'ai souvent.
>
> Quel message as tu lors du boot ?
>
> Je résoud le problème en éditant le fichier "/boot/grub/grub.cfg"
> et constate que les UUID dans une séquence de boot
> ne sont pas les mêmes (donc crash assuré au boot).
> Et pourtant avant, j'avais tapé "update-grub2".
>
> Il est aussi préférable de copier le même grub.cfg
> sur toutes les partitions Linux de ton ordinateur.
>
> Une fois les bons UUID remis, je tape :
> grub-install /dev/sda
> et ça remarche.
>
> Mais peut-être chez toi, c'est une autre cause ?
>
Il me semble que ce que tu indiques c'est valable pour du grub-pc mais pas pour
de l'efi.

Gaëtan



signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

[resolu] Re: [testing] PC ne boot plus

Gaëtan PERRIER-3
In reply to this post by Gaëtan PERRIER-3
Le lundi 05 novembre 2018 à 23:23 +0100, Gaëtan Perrier a écrit :
> Bonjour,
>
> Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
> Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir
> lancer
> debian.
> Quelqu'un d'autre rencontre-t'il ce problème?
>

J'ai résolu le problème en suivant les instructions de la première réponse de
cette page:
https://unix.stackexchange.com/questions/379774/grub-installation-failed

----------------------------------------------
Fixed that by deleting dump files :

# rm /sys/firmware/efi/efivars/dump-*

And then ran the usual

update-grub
grub-install -v --target=x86_64-efi --recheck /dev/sda

and it ran successfully!
----------------------------------------------


Maintenant ça boote correctement.

Gaëtan

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [resolu] Re: [testing] PC ne boot plus

Pascal Hambourg-2
Le 07/11/2018 à 00:49, Gaëtan Perrier a écrit :

>>
>> Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
>> Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir
>> lancer
>> debian.
>
> J'ai résolu le problème en suivant les instructions de la première réponse de
> cette page:
> https://unix.stackexchange.com/questions/379774/grub-installation-failed
>
> ----------------------------------------------
> Fixed that by deleting dump files :
>
> # rm /sys/firmware/efi/efivars/dump-*

L'as-tu fait spontanément ou après avoir constaté que grub-install
échouait avec une erreur relative à la création de l'entrée d'amorçage EFI ?

Cette action sert à libérer de la mémoire dans la NVRAM servant à
stocker les variables EFI et notamment les entrées d'amorçage manipulées
par efibootmgr.

Dans la sortie d'efibootmgr, on peut voir que l'entrée "debian" avait
disparu. Il se peut que sa re-création ait échoué par manque d'espace.
C'est une erreur assez courante.

> update-grub

Inutile.

> grub-install -v --target=x86_64-efi --recheck /dev/sda

Le paramètre /dev/sda est ignoré en mode EFI.

Note que puisque tu n'as pas de multi-boot, il existe un moyen simple de
se protéger contre la suppression de l'entrée d'amorçage EFI : installer
GRUB EFI dans le chemin de support amovible avec l'option --removable.
Avec dans la configuration du paquet grub-efi-amd64 modifiable avec
dpkg-reconfigure, il faut répondre oui à la question sur le chemin de
support amovible.

Reply | Threaded
Open this post in threaded view
|

Re: [resolu] Re: [testing] PC ne boot plus

Gaëtan PERRIER-3
Le mercredi 07 novembre 2018 à 07:53 +0100, Pascal Hambourg a écrit :

> Le 07/11/2018 à 00:49, Gaëtan Perrier a écrit :
> > > Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
> > > Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir
> > > lancer
> > > debian.
> >
> > J'ai résolu le problème en suivant les instructions de la première réponse
> > de
> > cette page:
> > https://unix.stackexchange.com/questions/379774/grub-installation-failed
> >
> > ----------------------------------------------
> > Fixed that by deleting dump files :
> >
> > # rm /sys/firmware/efi/efivars/dump-*
>
> L'as-tu fait spontanément ou après avoir constaté que grub-install
> échouait avec une erreur relative à la création de l'entrée d'amorçage EFI ?
Après que grub-install m'ait renvoyé une erreur.

[...]

>
> > update-grub
>
> Inutile.

Oui mais comme j'avais fait pas mal de manip je me suis dit que ça ne coûtait
rien de le faire.

>
> > grub-install -v --target=x86_64-efi --recheck /dev/sda
>
> Le paramètre /dev/sda est ignoré en mode EFI.

Ah bon? Pourtant on le voit sur tous les tutos que j'ai pu consulter.

>
> Note que puisque tu n'as pas de multi-boot, il existe un moyen simple de
> se protéger contre la suppression de l'entrée d'amorçage EFI : installer
> GRUB EFI dans le chemin de support amovible avec l'option --removable.
> Avec dans la configuration du paquet grub-efi-amd64 modifiable avec
> dpkg-reconfigure, il faut répondre oui à la question sur le chemin de
> support amovible.

J'ai fait la manip, merci.

A+

Gaëtan


signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [resolu] Re: [testing] PC ne boot plus

Pascal Hambourg-2
Le 07/11/2018 à 23:11, Gaëtan Perrier a écrit :
> Le mercredi 07 novembre 2018 à 07:53 +0100, Pascal Hambourg a écrit :
>> Le 07/11/2018 à 00:49, Gaëtan Perrier a écrit :
>>
>>> grub-install -v --target=x86_64-efi --recheck /dev/sda
>>
>> Le paramètre /dev/sda est ignoré en mode EFI.
>
> Ah bon? Pourtant on le voit sur tous les tutos que j'ai pu consulter.

Pour GRUB EFI, vraiment ? Cela renforce le peu de crédit que j'accorde
aux tutoriels en général.

Ce paramètre n'a de sens que pour GRUB BIOS, où il sert à indiquer
l'emplacement du secteur d'amorce (boot image). Il n'y a pas de secteur
d'amorce en UEFI.