upgrade Buster zfs Fehler

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

upgrade Buster zfs Fehler

Christoph Hilberg
Hallo Zusammen

Vorgeschichte
Auf einem Server mit zfs-Filesystem für Daten, habe ich vor längerem ein
Update von strech auf buster durchgeführt. Den Upgrade-Prozess für das
zfs-System mußte zweimal durchlaufen werden. Sonst gab es keine
Unauffälligkeiten.

Buster Upgrade von 10.3 auf 10.4
Hierbei lieft das upgrade des zfs-systems nicht sauber. Ich vermutete
das es an der Neukompilierung und dem Kernelwechsel lag. Seid dem hängt
das zfs-zed und zfsutils-linux im upgrade Prozess fest, status
unconfigured.
Beim Starten des Systems kommt es zu folgender Meldung:

● zfs-mount.service - Mount ZFS filesystems
  Loaded: loaded (/lib/systemd/system/zfs-mount.service; enabled;
vendor preset: enabled) Active: failed (Result: exit-code) since
 Fri 2020-05-22 13:03:06 CEST; 32min ago Docs: man:zfs(8)
  Process: 7648 ExecStart=/sbin/zfs mount -a (code=exited,
status=1/FAILURE) Main PID: 7648 (code=exited, status=1/FAILURE)

systemd[1]: Starting Mount ZFS filesystems...
zfs[7648]: cannot mount '/zp03': directory is not empty
systemd[1]: zfs-mount.service: Main process exited, code=exited,
status=1/FAILURE
systemd[1]: zfs-mount.service: Failed with result 'exit-code'.
systemd[1]: Failed to start Mount ZFS filesystems.

dpkg --configure -a oder apt-get upgrade ergänzt die Meldung um
folgende Informationen:
dpkg: Fehler beim Bearbeiten des Paketes zfsutils-linux (--configure):
 »installiertes zfsutils-linux-Skript des Paketes
post-installation«-Unterprozess gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von zfs-zed:
 zfs-zed hängt ab von zfsutils-linux (>= 0.7.12-2+deb10u2); aber:
  Paket zfsutils-linux ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes zfs-zed (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 zfsutils-linux
 zfs-zed

De facto ist das System aber gemountet. Scheint demnach nicht das
Problem zu sein.

In meiner Not habe ich zfs schon einmal deinstalliert und wieder
draufgepackt, das hatte keine Veränderung gebracht.

Hat jemand einen sachdienlichen Hinweis oder sonst einen Gedanken, der
mich aus meiner Schleife befreit?

Vielen Dank Christoph


Reply | Threaded
Open this post in threaded view
|

Re: upgrade Buster zfs Fehler

Hilmar Preuße
Am 22.05.2020 um 14:11 teilte Christoph Hilberg mit:

Moin,

> Hat jemand einen sachdienlichen Hinweis oder sonst einen Gedanken, der
> mich aus meiner Schleife befreit?
>
Steht doch da:

systemd[1]: Starting Mount ZFS filesystems...
zfs[7648]: cannot mount '/zp03': directory is not empty
systemd[1]: zfs-mount.service: Main process exited, code=exited,

Das Verzeichnis was als Mount point verwendet werden soll ist nicht leer.

H.
--
sigfault
#206401 http://counter.li.org


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: upgrade Buster zfs Fehler

Christoph Hilberg
Am Fri, 22 May 2020 16:32:59 +0200
schrieb Hilmar Preuße <[hidden email]>:

> Steht doch da:
>
> systemd[1]: Starting Mount ZFS filesystems...
> zfs[7648]: cannot mount '/zp03': directory is not empty
> systemd[1]: zfs-mount.service: Main process exited, code=exited,
>
> Das Verzeichnis was als Mount point verwendet werden soll ist nicht
> leer.
>
> H.

Hallo Hilmar

ja das habe ich gelesen. Hier gibt es ja auch noch weitere Mountpionts.
zfs list gibt die aus. Auf einem anderen Server genauso.

Also was ist falsch

Reply | Threaded
Open this post in threaded view
|

Re: upgrade Buster zfs Fehler

Ulf Volmer
On 22.05.20 17:05, Christoph Hilberg wrote:

> Am Fri, 22 May 2020 16:32:59 +0200
> schrieb Hilmar Preuße <[hidden email]>:
>> Steht doch da:
>>
>> systemd[1]: Starting Mount ZFS filesystems...
>> zfs[7648]: cannot mount '/zp03': directory is not empty
>> systemd[1]: zfs-mount.service: Main process exited, code=exited,
>>
>> Das Verzeichnis was als Mount point verwendet werden soll ist nicht
>> leer.

> ja das habe ich gelesen. Hier gibt es ja auch noch weitere Mountpionts.
> zfs list gibt die aus. Auf einem anderen Server genauso.

Ich würde ein

zpool export <poolname>
/zp03 inspizieren und aufräumen
zpool import <poolname>

vorschlagen.

Viele Grüße
Ulf

Reply | Threaded
Open this post in threaded view
|

Re: upgrade Buster zfs Fehler

Christoph Hilberg
Am Fri, 22 May 2020 17:53:53 +0200
schrieb Ulf Volmer <[hidden email]>:
> Ich würde ein
>
> zpool export <poolname>
> /zp03 inspizieren und aufräumen
> zpool import <poolname>
>
> vorschlagen.
Hallo Ulf

ich habe

zpool export <poolname>
apt-get upgrade (rödel, erstellt neue Links usw)
%Läuft sauber durch%
zpool import <poolname>

ausgeführt

Problem weg

super danke Christoph


Reply | Threaded
Open this post in threaded view
|

Re: upgrade Buster zfs Fehler

Ulf Volmer
On 22.05.20 18:22, Christoph Hilberg wrote:

> Am Fri, 22 May 2020 17:53:53 +0200
> schrieb Ulf Volmer <[hidden email]>:
>> Ich würde ein
>>
>> zpool export <poolname>
>> /zp03 inspizieren und aufräumen
>> zpool import <poolname>
>>
>> vorschlagen.
> Hallo Ulf
>
> ich habe
>
> zpool export <poolname>
> apt-get upgrade (rödel, erstellt neue Links usw)
> %Läuft sauber durch%
> zpool import <poolname>
>
> ausgeführt
>
> Problem weg

Ich fürchte, wenn Du /zp03 nicht aufgeräumt hast, wirst Du das Problem
beim nächsten Kernel- Upgrade wieder bekommen.

Viele Grüße
Ulf